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Overview
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Overview

This document provides an explanation of the steps required to perform a Microsoft Access to 
FileMaker Pro Migration project using FmPro Migrator. This migration process includes the 
migration of Tables/Fields, data, Relationships, Value Lists, Forms/Reports and Visual Basic 
code.

Revision 20
4/14/2024

[Revision Notes: Updated for FmPro Migrator Platinum Edition 11.01.
Added new Licensing FmPro Migrator info, updated screenshots.]
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Licensing FmPro Migrator

As of FmPro Migrator v11, all FmPro Migrator downloads are fully functional with features 
unlocked via a single license key.
This section of the manual shows how to enter the license key to unlock the features within 
FmPro Migrator.

FmPro Migrator 11.01
4/14/2024

Demo Edition Dialog

When launched the first time, FmPro Migrator will be running in Demo mode as shown in this 
screenshot. Clicking the Ok button opens the order page of the website.
In addition to transferring data for 5 database fields, the conversion features shown on the GUI 
tab of the Migration Process window will convert 5 layouts or forms/reports & scripts.
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Demo Mode - About Tab

Clicking the "License" button on the About tab, or selecting the Help -> License/About menu items 
will open the About window where you can enter the license key.
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About/License Window

On the About FmPro Migrator window:
(1) Product name and version licensed, (2) Demo or Licensed will be displayed, (3) The Upgrade 
button opens the website order page, (4) Email address associated with your license key, (5) 
Clipboard button reads the license key from the clipboard, (6) License key field, (7) Email Support 
button opens the Contact form on the website, (8) Visit Website opens the order page in Demo 
mode or the product page in Licensed mode, (9) Check for Update opens the downloads page 
with the latest software version, (10) Ok button closes the About window.
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Pasting License Key

Your product license key will be displayed in your web browser when your order has been 
completed. It will also will be sent via email at the same time, please check your SPAM folder if 
the email doesn't arrive in a few minutes.

(1) Copy the license key to the clipboard and click the clipboard icon. Once validated (2) the 
product name will change, (3) the License validation date will be updated, (4) your email address 
will be displayed, and (5) the license key will be displayed in the field under the Email address 
when clicking inside the field. In this screenshot the license key has been obscured.

And that is all you need to do to license all of the features of FmPro Migrator.



FmPro Migrator - Access to FileMaker Migration Procedure - 10

Step 1



FmPro Migrator - Access to FileMaker Migration Procedure - 11

Office 365 Compatibility

Previously, Microsoft Office 365 was incompatible with the installation of the ACEODBC.dll file 
required to provide support for reading or writing Access .accdb database files by external 
applications via ODBC. This problem is now resolved with Office 365 installations in 2023 when 
running the offline installer.

Installing Microsoft 365 Access Runtime - for ODBC Driver [Optional]

This step can probably be skipped as of 2023.

Testing being done in June 2023 shows that the Access 2016 32-bit and 64-bit  ODBC drivers are 
being installed with the Office 365 offline installer: O365HomePremRetail.img (4.7GB). You only 
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need to install this runtime if the installer didn't install the ODBC driver.

But after installing the runtime, you will probably need to uninstall the runtime - which will leave 
the ODBC driver in place. Testing after installing the runtime caused problems with Access which 
prevented seeing any of the tables/fields or data within the database since the runtime was being 
used instead of the full copy of the Access database application.

The URL for this Microsoft 365 Runtime is currently located as follows:

https://support.microsoft.com/en-us/office/download-and-install-microsoft-365-access-runtime-185c5a32-8ba9-491e-ac76

FmPro Migrator Office 365 Error Dialog - Importing .accdb Files [Obsolete]

This error should no longer occur with new Office 365 installations. New installations are 
installing the ODBC driver and it works correctly on x86-64 hardware. This note in the manual is 
just for historical and documentation purposes - and should not occur with newer versions of 
Office 365 as of 2023.
If this error occurs, please send an email via the Contact page on the FmProMigrator website. The 
code which checks for this registry key still remains in FmPro Migrator, but should not get 
triggered anymore.

https://support.microsoft.com/en-us/office/download-and-install-microsoft-365-access-runtime-185c5a32-8ba9-491e-ac76-91cbe3ea09c9
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FmPro Migrator Office 365 Error Dialog - Exporting to .accdb Files [Obsolete]

This error should no longer occur with new Office 365 installations as of 2023. Previously, this 
error could occur when creating a table or transferring data into an Access .accdb file.
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Office 365 - Offline Installer

By default, Microsoft will use the ClickToRun installer. You should download the offline installer. 
The offline installer includes both 32-bit and 64-bit versions of Office software.
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FmPro Migrator is available in both 32-bit and 64-bit versions which are both included with your 
purchase. You should match the version of FileMaker Pro which you have installed. For instance, 
if the copy of FileMaker Pro is 64-bit, then all of the rest of the software should also be 64-bit. 

Access ODBC Driver Error 193 - Windows 11 ARM

The remaining issues with Office 365 or Access 2016 ODBC functionality at this time, seems to 
be when running on Windows 11 ARM.
1) When creating/updating a 64-bit ODBC DSN, error 193 is displayed. Manually editing the 
registry entries has not solved this issue. A 32bit DSN can be created and edited, but the .mdb 
driver doesn't support .accdb files. It may be possible to convert .accdb files into .mdb files, but 
features may be lost.
2) The system created links to the 32-bit and 64-bit ODBC Administrator EXE files are not created 
properly and need created manually for the Start menu.

These problems don't occur with Windows 11 on x86-64 CPUs.
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Step 1 - Get Info - Access to FileMaker Pro

FmPro Migrator uses the information within the Access mdb/accdb file to perform the conversion 
of tables/fields and data from Microsoft Access to FileMaker Pro.  FmPro Migrator can be running 
on macOS or Windows in order to perform the conversion. It is not necessary to have a copy of 
Access running on the computer which is being used to perform the conversion, but FileMaker 
Pro is required.
When using FmPro Migrator on macOS, the Actual Technologies  ODBC Driver for Access is 
required.

Step 1 - Click FileMaker Tab

Launch FmPro Migrator, then click on the FileMaker tab at the top of the window.

http://www.actualtech.com
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Step 1 - Get Info - Select Output Directory

FmPro Migrator stores migration process information within a SQLite database file named 
MigrationProcess.db3. This file contains the metadata for the source Access database file, 
including tables, fields, table creation SQL code and status info. Therefore the first step in the 
migration process is to click the Browse button to select the output folder FmPro Migrator will use 
when creating the MigrationProcess.db3 file. 

(1) Select the output directory, then (2) select Access from the Source Database menu.
(3) Create an ODBC DSN to the FileMaker database using the name already shown in the 
Destination Database ODBC DSN field. Or you may create an ODBC DSN with a different name 
and enter the name in this field.
[Details are provided in the following pages for installing FileMaker ODBC drivers and creating the 
ODBC DSN.]

Note: FmPro Migrator will automatically create a File DSN to read table info from the Access 
database. But you should create an ODBC DSN (shown later) when transferring data from Access 
to FileMaker [on Windows].
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Continue Migration...

Tip: To restart an existing migration project, select the output directory, then select Continue 
Migration... from the File menu.
Click the yellow Continue button to open the Migration Process window.

Step 1 - Get Info - Drag & Drop Access File

Drag & Drop the Access file onto the Step 1 Get Info icon.

Step 1 - Get Info - Troubleshooting

Note: FmPro Migrator makes a file DSN connection to read the structure info from the Access 
database file. On macOS, this process requires the Actual ODBC Driver for Microsoft Access from 
Actual Technologies (www.actualtech.com).

On Windows, the Microsoft Access ODBC driver is pre-installed when Microsoft Access is 
installed.

http://www.actualtech.com
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Step 1 - Get Info - Select Continue... Menu

After the Gathering Info... dialog disappears, select the File -> Continue Migration... menu or click 
the yellow Continue... button.
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Step 1 - FileMakerDB & Migration Process Windows

After Continue Migration has been selected, the Migration Process window will open. FmPro 
Migrator will also save a FileMaker template database file named FileMakerDB.fp7/.fmp12 to the 
output directory and will open the FileMaker database file.
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Install FileMaker ODBC Driver - macOS (FileMaker 11+)

Download ODBC Manager

Download and install the free ODBC Administrator for macOS from www.odbcmanager.net

You will use the ODBC Administrator to create and manage your ODBC DSNs on macOS.

http://www.odbcmanager.net


FmPro Migrator - Access to FileMaker Migration Procedure - 22

Install the FileMaker ODBC Driver

(1) Open the xDBC folder on the FileMaker install CD (or installer image DMG file).
(2) Double-click the FileMaker ODBC.mpkg installer to install the FileMaker ODBC driver. Follow 
the insular prompts.
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Add a System DSN

(1) Click the System DSN tab, then (2) click the Add button.
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Choose the FileMaker ODBC Driver

(1) Select the FileMaker ODBC driver from the list, (2) click the Ok button.
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FileMaker ODBC DSN Configuration - Page 1

Click the Continue button.
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FileMaker ODBC DSN Configuration - Page 2

(1) Enter a name for the FileMaker ODBC DSN. The name used here needs to be exactly the 
same as the ODBC DSN Name you enter into FmPro Migrator. 
(2) Click the Continue button.
Note: You can pick a different name than you see here, just make sure that you enter exactly the 
same name into FmPro Migrator.
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FileMaker ODBC DSN Configuration - ODBC DSN Field in FmPro Migrator

In this screenshot, the FileMaker 11 database is the destination database, therefore the FileMaker 
ODBC DSN name is entered in the Destination Database ODBC DSN field.
If the FileMaker database was the source database, and the data was being copied to a different 
database server, then the FileMaker ODBC DSN would be entered into the ODBC DSN field for 
the Source Database (not shown in this screenshot).
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FileMaker ODBC DSN Configuration - Page 3

(1) Enter the hostname for the FileMaker database (default is localhost).
(2) Click the Continue button.
For a file which has been opened on your local desktop machine, leave the default setting of 
localhost.
For a hosted file hosted by FileMaker Server Advanced, enter the IP Address or hostname of the 
FileMaker Server Advanced computer.
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FileMaker ODBC DSN Configuration - Page 4

(1) For most locally hosted database files, enter the text "Default" into the Database field, instead 
of selecting a database from the list. This way you can use any single database file without 
re-selecting the database name each time you open a new file. 
To use this feature, you must only have one FileMaker database file open at a time, or an error will 
occur when attempting to read info from the database.
(2) Click the Advanced Language button.
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FileMaker ODBC DSN Configuration - Page 5

(1) Un-check the Auto-detect language settings checkbox.
(2) Select UTF-8 from the Multi-byte text encoding menu.
(3) Click the Ok button.
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FileMaker ODBC DSN Configuration - Page 4

(1) Click the Continue button.
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FileMaker ODBC DSN Configuration - Page 5

(1) Click the Test button.
If the test fails, use the following steps to enable ODBC sharing for the FileMaker database. 
Note: Each FileMaker database needs to have ODBC sharing enabled individually.

FileMaker ODBC DSN Configuration - Page 5 - ODBC DSN Test

Enter the (1) Username, (2) Password, then (3) click the Ok button to test the ODBC DSN.
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FileMaker ODBC DSN Configuration - Page 5 - ODBC DSN Test

(1) Click the Ok button.
If the test passes, this dialog will be displayed, showing that the ODBC Driver Manger has used 
this ODBC DSN to successfully connect to the FileMaker database.

If the test fails:
1) Verify that the FileMaker database file is open.
2) Verify that FileMaker ODBC sharing is enabled for the account entered in the connection test 
dialog prompt.
4) Make sure that there aren't two different copies of FileMaker running at the same time. Both 
older and current versions of FileMaker use TCP/IP Port# 2399 for ODBC connectivity. If this type 
of conflict occurs, close both versions of the FileMaker application, and only open the one copy 
you want to serve the database file being migrated.
5) Try rebooting the computer (after clicking Ok to save changes and close this ODBC dialog). 
Then test the DSN again after rebooting.
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FileMaker ODBC DSN Configuration - Page 5

(1) Click the Done button to save the new ODBC DSN.
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Enable ODBC/JDBC Sharing within FileMaker Pro

ODBC/JDBC Sharing needs to be enabled within any FileMaker Pro database file which is going 
to be used with the FileMaker ODBC driver.
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Select Sharing Parameters

(1) Turn on ODBC/JDBC Sharing, (2) for the currently open FileMaker Pro database file, (3) for All 
Users, then (4) click the Ok button.
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Install FileMaker ODBC Driver - Windows - FileMaker 11+

Install the FileMaker ODBC driver from within the xDBC folder on the installation CD or CD image 
file.

Downloading the FileMaker ODBC Driver

The FileMaker ODBC driver is also available from the Claris support website:
https://www.claris.com/resources/downloads/

On this web page, look for the item labelled: 
xDBC update for FileMaker Platform

This item will link to the page shown in this screenshot, the actual URL has a very specific 
document number, which might change - so it is best to start with the downloads page.
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32-Bit Versus 64-Bit Installations - FileMaker Pro

Starting with FileMaker Pro 19, only 64-bit versions are available for installation. Earlier versions of 
FileMaker may include both 32-bit and 64-bit versions. To find the version of FileMaker running on 
your computer:
1) Select the Help -> About FileMaker Pro Advanced menu. 2) Click the Info button as shown 
above to see the Application Architecture.

If you are running the 64-bit version of FileMaker Pro, then you want to be using the 64-bit version 
of FmPro Migrator and the 64-bit version of the ODBC Administrator to create the ODBC DSN.
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FmPro Migrator - 64bit

Both 32-bit and 64-bit versions of FmPro Migrator are available. The About screen shows which 
version you are running.
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Create ODBC DSN - Windows

To create a new System ODBC DSN, open the Control Panel > Administrative Tools > Data 
Sources (ODBC) Control Panel.
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64-bit ODBC Data Source Administrator

The 64-bit ODBC Administrator shown in this screenshot is available from the path:
%windir%\system32\odbcad32.exe

Both 32-bit and 64-bit ODBC DSNs are displayed in the ODBC Administrator, as shown in the 
Platform column of the listing. 

Running under Windows 10, it shows (64-bit) in its window title when running.
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32-bit ODBC Administrator

The 32-bit ODBC Administrator is available from the path:
%windir%\syswow64\odbcad32.exe

This screenshot is from an earlier version of Windows, which doesn't show the Platform type in 
the list of ODBC DSNs and it also doesn't show in its title whether it is running 32-bit or 64-bit.

(1) Click the System DSN tab, then (2) click the Add button.
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Select ODBC Driver - FileMaker 11 - Windows

(1) Select the FileMaker ODBC driver, then (2) click the Finish button.

ODBC Driver Configuration - FileMaker 11+ - Windows (1)

Click Next button.
Click the About button if you need to find the version number for the driver.
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ODBC Driver Configuration - FileMaker 11+ - Windows (2)

1) Enter a name for the ODBC DSN, (2) click the Next button.

ODBC Driver Configuration - FileMaker 11+ - Windows (3)

1) If you are using a local copy of FileMaker Pro or FileMaker Pro Advanced, then use "localhost" 
as the host name. Otherwise use the IP address or hostname of the FileMaker Advanced Server.
2) You may optionally click the "Connect to host ..." button to get a list of database files.
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3) Click the Next button.

ODBC Driver Configuration - FileMaker 11+ - Windows (4)

1) Enter "Default" as the database name. Or if you have multiple database files open locally or on 
the server, then select the database name from the list or enter the name of the database. Using 
the Default keyword means that you can avoid changing the setup of the ODBC DSN when using 
different database files - but it means that only one file can be open at a time.
2) Click the Advanced Language button.
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ODBC Driver Configuration - FileMaker 11 - Windows (5)

1) Uncheck the "Auto-detect language settings" button, 2) select System (WinLatin1) for the text 
encoding, 3) click the Ok button.

It has been found that for proper character encoding, the following configuration works well:
1) Install matching platform versions (64-bit or 32-bit) of the FileMaker database and FmPro 
Migrator on Windows.
2) In the FileMaker ODBC driver, disable the Auto-Detect Language checkbox in the Advanced 
Language dialog.
3) Set the Multi-byte Text Encoding menu to UTF-8 in the Advanced Language dialog.
For SQL Server:
4) Enable the Perform Translation for Character Data checkbox on the last panel of the SQL 
Server ODBC DSN configuration.
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ODBC Driver Configuration - FileMaker 11+ - Windows (6)

Click the Next button.

ODBC Driver Configuration - FileMaker 11+ - Windows (7)

Click the Test button.
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ODBC Driver Configuration - FileMaker 11+ - Windows (8)

1) Enter Username, 2) Password (if needed), 3) click the Ok button.
Review the test results, make corrections as necessary until the test passes.
ODBC Error Troubleshooting Steps:
1) Verify that the FileMaker database file is open.
2) Verify that ODBC sharing is enabled for the account entered in the connection test dialog 
prompt.
3) Make sure that there aren't two different copies of FileMaker running at the same time. Both 
older and current versions of FileMaker use TCP/IP Port# 2399 for ODBC connectivity. If this type 
of conflict occurs, close both versions of the FileMaker application, and only open the one copy 
you want to serve the database file being migrated.
4) Try rebooting the computer (after clicking Ok to save changes and close this ODBC dialog). 
Then test the DSN again after rebooting.

ODBC Driver Configuration - FileMaker 11+ - Windows (9)

Click the Finish button.
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Step 2
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Step 2 - Create Tables

At this point in the process, the FileMaker ODBC driver should be installed. The Access tables can 
be created in FileMaker Pro either by pasting the tables into FileMaker Pro Advanced via the 
ClipBoard, or via the FileMaker Pro ODBC DSN created earlier.

Note: Starting with FileMaker 16, both FileMaker Pro and FileMaker Pro Advanced allow 
copying/pasting of tables via the clipboard - so the older ODBC method is no longer detailed in 
this manual.

Step 2 - Create Tables via ClipBoard - Using FileMaker Pro Advanced

If FileMaker Pro Advanced is being used, it is faster to create the tables by pasting the Table XML 
code via the ClipBoard. 

This process creates all of the tables at once, without requiring each table to be clicked in the list 
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of tables.

Click the Copy All Tables to ClipBoard button on the Tables Tab of the Migration Process window.

Step 2 - Create Tables via ClipBoard - WinAutomation

While gathering info from the Access file, FmPro Migrator created and opened a new empty 
FileMaker Pro database file named FileMakerDB.fp7/.fmp12 within the output directory.

FmPro Migrator will install and run a WinAutomation Robot (or AppleScript on macOS) which will 
automatically open the Manage Database window, and will also click the Tables tab.

Just click the Paste button to paste the tables which have already been copied to the clipboard by 
FmPro Migrator.

Note: Starting with FileMaker 16, both FileMaker Pro and FileMaker Pro Advanced allow 
copying/pasting of tables via the clipboard.
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Step 2 - Create Tables via ClipBoard - Define/Manage Database... Menu - Manual Process

While gathering info from the Access file, FmPro Migrator created and opened a new empty 
FileMaker Pro database file named FileMakerDB.fp7/.fmp12 within the output directory.

If the WinAutomation Robot (or AppleScript on macOS) doesn't run, you can open the Manage 
Database window manually.

Select Define/Manage Database... from the File menu within FileMaker Pro Advanced.
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Step 2 - Create Tables via ClipBoard - Paste Tables

(1) Click the Tables tab (if necessary), (2) then click on the Paste button.

Note: If the Paste button is grayed out, this means that the table XML code didn't get copied to the 
ClipBoard before the Define/Manage Database dialog was opened. If this happens, click the Copy 
All Tables to ClipBoard button again from within FmPro Migrator. Switching from the Fields tab 
and then switching back to the Tables tab will cause FileMaker Pro Advanced to check the 
ClipBoard again for Table XML info. When the Table XML code is found on the ClipBoard, the 
Paste button will be enabled.
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Step 2 - Create Tables via ClipBoard - Paste Tables Result

The new tables will be created and then displayed within the Tables list. FileMaker Pro Advanced 
will also create a basic layout and a TO on the relationship graph for each of these new tables.

Click the Ok button to close the Manage Database window.
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Step 3
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Step 3 - Transfer Data - Access to FileMaker Pro

On macOS a File DSN is used to connect to the Access database for transferring data.
On Windows a User or System DSN needs created to connect with the Access database.

Configure Access ODBC DSN Name - Windows

Create an ODBC DSN for the Access database file matching the name shown in the Table 
Details window, and enter the name of the new ODBC DSN in the Source DSN field on the Table 
Details window. It is not usually necessary to enter a username/password for Access database 
files.
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Access ODBC DSN Creation - Windows

Select the name of the Access database file (1) (2) in the Database Name pane. (3) Click the Ok 
button.
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Step 3 - Transfer Data - Windows

(1) Click a table in the list of tables, (2) then click the Step 3 Transfer Data button to transfer data 
for the selected table from Access into FileMaker Pro.

Repeat this process for each table in the Access database file.
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Data Transfer Method - Windows - xferDataPerl.exe

On Windows, the command prompt window will open, and will display the results of transferring 
the data from the Access database into FileMaker Pro.  This window will then close automatically 
once the data has been transferred.
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Step 3 - Transfer Data - macOS

(1) Click a table in the list of tables, (2) then click the Step 3 Transfer Data button to transfer data 
for the selected table from Access into FileMaker Pro. A file DSN is used to connect to the Access 
database on macOS using the Actual Technologies ODBC for Access driver, so it isn't necessary 
to create a User or System DSN with ODBC Manager. 
As shown in Step #2 - a DSN does need created for the FileMaker database - as shown in the 
Step #2 instructions.

Repeat this process for each table in the Access database file.
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Troubleshooting - No such table

This error can mean that the ODBC DSN specified in FmPro Migrator for the Source Database 
(the Access database), does not point to the correct Access database file. This DSN needs to be 
changed each time a new Access database file is processed by FmPro Migrator.

Note: This warning dialog suggests that tables containing spaces and special characters may 
not be read properly. This is not always the case, it is just something to review and change if 
problems occur when transferring data. 
Recent improvements in the design of the FmPro Migrator data transfer scripts will allow many of 
these tables to work just fine because the table names are enclosed with square brackets.
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Step 3 - Transfer Data - Access to FileMaker Import Scripts

FmPro Migrator versions 10.07 and higher include a new File -> Create Access Import Scripts 
menu item. This menu item creates FileMaker import scripts for each Access database table and 
can be used at any time to truncate and re-import the data from Access databases into FileMaker 
Pro.

Note: These scripts can be used to import data from any ODBC database into FileMaker Pro on 
macOS or Windows. You will need to create an ODBC DSN for the source database and enter the 
username/password info into the Import Records script step.

Select File -> Create Access Import Scripts

Select the File -> Create Access Import Scripts to create the ODBC import scripts.

Import Scripts Created Dialog

Click the Ok button.
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Paste Scripts into FileMaker Script Workspace

Click the top script in the list, then select the Edit -> Paste menu or Command/Control V to paste 
the scripts into the Script Workspace.

Verify Layout Name - Each Import Script

It is not always possible for FmPro Migrator to identify the correct layout name to be used for each 
import and Truncate Table script. So it is important to verify the name of each layout you want to 
use for each table import.
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Edit Import Parameters (1)

Click Specify... button.

Edit Import Parameters (2)

(1) By default, FmPro Migrator sets a user name of "1" for the ODBC import dialog because 
FileMaker doesn't seem to allow a blank value. On macOS, the Actual Technologies ODBC for 
Access driver doesn't require or use any login info when connecting to Access database files.
Also - FmPro Migrator uses the ODBC DSN shown for the source Access database on the main 
screen. Changing this default name of "example_acs_dsn" will use the value you configure when 
generating the scripts.
(2) Check the "Save username and password" check box so that the scripts can run without 
prompting.
(3) Click the Ok button.



FmPro Migrator - Access to FileMaker Migration Procedure - 65

Edit Import Parameters (3)

Verify the selection of the Target Fields, then click the Ok button to save the changes and save the 
script changes in the Script Workspace.
Test each individual script, then test the _Import All Tables script.
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Migrating Forms/Reports, 
Relationships, Value Lists & 

Visual Basic Code
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AccessDDRExport - Extracting Info From Access (FileMaker Pro Migration)

FmPro Migrator Platinum Edition includes features for migrating Microsoft Access Forms/Reports, 
Queries, Relationships, Value Lists and Visual Basic code into FileMaker Pro.
These features utilize AppleScript/WinAutomation to automate the process of creating the objects 
within the FileMaker database file, along with the Access to FmPro Migration Service feature on 
the GUI tab of FmPro Migrator Developer Edition.

Access to FmPro Migration Service button

Click the Access to FmPro Migration button on the GUI tab within FmPro Migrator Platinum Edition.
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Access to FmPro Migration Window

Clicking the Access to FmPro Migration Service button opens the Access to FmPro Migration 
Service window.
As this window is opened, the AccessDDRExport.zip file is written into the output directory. 
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AccessDDRExport.zip Contents

Extract the files from this zip archive.

The files within this zip archive include:
AccessDDRExport??.accdb - An unsigned Access 2010+ DDR Export database file, created with 
Access 2016.
AccessDDRExport??.mdb - The Access 2000/2003 DDR Export database file.
AccessDDRExportSaveImage.exe - A digitally signed 32-bit VB6 compiled EXE which extracts 
images from Access forms/reports by using the ijl15.dll within the same folder.
ijl15.dll - A digitally signed 32-bit dll licensed from Intel which is used to extract images from 
Access forms/reports. This dll no longer needs to be installed into the Windows folder.

AccessDDRExport.accdb - Security Notice

The Access 2010/2016 ACCDB file always disables active content until the "Enable Content" 
button is clicked.

Overview - Using the AccessDDRExport.accde/.mde Database Files

The process for extracting Forms/Reports, Queries, Value Lists and Visual Basic code from 
Access database files requires running one of the two Microsoft Access Export database files on 
a computer or virtual machine running Windows. These database files cannot be used with 
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CodeWeavers CrossOver Mac. They must be run under a full copy of Windows with a full copy of 
Microsoft Access.
The AccessDDRExport.accde/mde database creates a database design report text file within a 
top-level folder having the same name as the selected Microsoft Access database file. Images 
embedded within the Forms/Reports are exported into an Images folder within the top-level folder. 
Once the database design report and images have been extracted from the Access database file, 
the top-level folder and its contents may be copied between computers and used on either 
macOS or Windows to complete the migration process.

AccessDDRExport - AccessDDRExportSaveImage.EXE and ijl15.dll on Windows

Before running the AccessDDRExport.accde/mde database files, the ijl15.dll and 
AccessDDRExportSaveImage.exe files both need to be located within the same folder as the 
AccessDDRExport??.accdb/mdb files. This is the default location for these files when the folder is 
unzipped, so unless these files get moved or renamed, the error message shown above won't be 
displayed.
These two files are used for extracting the embedded images from Microsoft Access 
Forms/Reports. If these files are not installed, the rest of the database design report creation 
process will work Ok, but the images won't be processed.

After these files have been restored to the same folder, re-launch the 
AccessDDRExport.accdb/mdb database.
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AccessDDRExport - Exporting the Database Design Report

Launch the AccessDDRExport.accdb/mdb database file. 
Click the Select Database button.
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AccessDDRExport - Select Access Database

(1) Select the type of Access database file to be opened (accdb/mdb), (2) select the database file, 
then click the Open button.

Note: By default, .accdb files will be displayed in the open file dialog when running Access 2007 
and higher. 

AccessDDRExport - Processing Status

The selected Access database will be opened, and the processing status will be displayed in the 
lower left corner of the AccessDDRExport window. At the completion of the export process, the 
selected database file will be closed and the cursor will return to the arrow cursor and the status 
area text will change to "Processing Completed".
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AccessDDRExport - Results

The AccessDDRExport text file and the embedded Form/Report images will be extracted into a 
folder within the same directory as the original Access database file. This folder can be copied to 
another computer if necessary for further processing by FmPro Migrator Developer Edition.
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Access to FmPro Migration - Select AccessDDR Text File

Click the Browse button to select the AccessDDR text file.
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Select the Access DDR Text File

(1) Select the text file created by the AccessDDRExport database, (2) click the open button.
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Access to FmPro Migration - Forms/Reports Count

FmPro Migrator will read the Access DDR text file, validate the format of the file and display the 
count of Forms and Reports within the file. 

Note: Even if there are no Forms/Reports within the file, Relationships and VBA code will still be 
imported.
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Using Licensed Mode -  Access to FmPro

Using the Access to FmPro Migration Service in Demo mode, limits processing tasks to 5 
Forms/Reports and 5 Visual Basic scripts. Ordering a license key lifts these operating limits for 
this service. Using the License Key allows for the processing of an unlimited number of database 
files and scripts for the purchased Forms/Reports quantity during the duration of the license key.

Migration Statistics - Licensed Mode

(1) Click the Migrate button to convert the AccessDDR text info into FileMaker layouts, value lists, 
scripts and relationships. A progress dialog will be displayed during the processing of the file.
Clicking the Migrate button with the license key enables the processing of the number of 
Forms/Reports as specified in the license key and the conversion of an unlimited number of 
Visual Basic scripts, with the (2) resulting processing statistics displayed the Migrate button. 
Value Lists will also be created from the Form/Report objects imported into FmPro Migrator. 
These Value Lists will be visible under the Value Lists tab of the Migration Process window after 
the completion of processing.
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Review Exported Visual Basic Files

The exported Visual Basic code has been converted into FileMaker Scripts formatted for pasting 
into the FileMaker scripts window. This code has also been saved as individual text files within 
the AccessDDR Info directory. 

Visual Basic Code Details

Each Visual Basic Subroutine or Function is extracted into a separate text file and corresponding 
FileMaker script (1) including the name of the original code module, (2) global variables for the 
enclosing code module, (3) followed by the actual text of the Subroutine or Function.
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Troubleshooting - Visual Basic Code

If the AccessDDRExport database reports that 0 Visual Basic modules were found within the file, 
verify that the Visual Basic code was compiled within the Access database. Uncompiled Visual 
Basic code will cause the number of code modules to be reported as 0.
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Creating TOs - Access to FmPro

During the migration process, FmPro Migrator creates additional TOs to represent each migrated 
Query. These additional TOs need to be created prior to creating relationships and layouts.

TOs List

Click on the TOs tab of the Migration Process window to display the list of TOs. Clicking on a TO in 
the list will display the details of the TO.
Click on the Create All TOs in FileMaker button to automate the creation of the TOs using 
WinAutomation(Windows)/AppleScript(macOS).
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     Create TOs Button

Click the TOs tab.

Click the Create All TOs in FileMaker button, to build the non-Base Table TOs within the 
destination FileMaker database file.
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Create Relationships - Windows WinAutomation Files

The first time you click the Create All TOs button on Windows, the WinAutomation Jobs folder will 
be created. The _FmPro Migrator WA Jobs.exe will be executed in order to perform the automation 
tasks sent by FmPro Migrator. 

The WinAutomationTester folder is a separate zip file which can be downloaded from the File 
menu of FmPro Migrator for testing purposes - but is not required for normal automation tasks.

macOS Note: On macOS, AppleScript is executed from within FmPro Migrator to perform the 
automation tasks. If you want to see the AppleScript automation source code, select the File 
menu option "Export AppleScript or WinAutomation scripts".
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Creating Relationships - Access to FmPro

Creating Relationships on Windows:
At the present time, FmPro Migrator is not able to automate the creation of relationships on 
Windows. This task can only be automated on macOS.

Relationships List

Click on the Relationships tab of the Migration Process window to display the list of converted 
relationships. Clicking on a relationship in the list will display the details of the relationship.
Click on the Create All Relationships in FileMaker button to automate the creation of the 
relationships using WinAutomation(Windows)/AppleScript(macOS).
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Created Relationships - Relationship Graph

After the relationships have been created, they can be observed on the FileMaker relationship 
graph. 
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Creating Value Lists - Access to FmPro

Value Lists - Overview

Click on the Value Lists tab of the Migration Process window to display the list of converted Value 
Lists. Clicking on a Value List  in the list will show the details for the selected Value List.

Microsoft Access does not contain a centralized list of value lists like FileMaker Pro. Value lists are 
embedded within Form/Report objects throughout the entire database. 
FmPro Migrator extracts value lists embedded within all fields in the Forms/Reports within the 
Access database file. A checksum is created for the contents of each value list during the 
migration processing. If a new value list is found, which matches the checksum of an existing 
value list, then the existing value list name is used to represent the value list when it is converted 
for use in FileMaker. Otherwise, a new value list will be created for use within the FileMaker 
database.
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Microsoft Access also embeds value list information within checkbox and radio button 
(acOptionGroup) objects. FmPro Migrator automatically extracts the numeric values assigned to 
each individual checkbox/radio button object, along with the associated text label. As shown in the 
screenshot, the numeric values are listed, followed by a semi colon and the text label value.

FmPro Migrator always creates the first value list named "Checkbox 1/0" for use with single 
(ungrouped) radio buttons and checkboxes.

FileMaker developers have a couple of options to choose from concerning how to handle the 
numeric values utilized within Access  value lists.

Option #1: If you have an Access database which will be used to refresh information within the 
FileMaker database on a regular basis, then you should continue to store numeric values within 
the FileMaker database fields. 
In this scenario, manually create a value list lookup table for each Access value list, and populate 
the table with the numeric and text values within the value list. Change the created value list to use 
values from the fields of the value list lookup table.

Option #2: If all of the functionality within the Access database will be permanently transferred into 
the FileMaker database, then follow the following steps:
1) Change the underlying FileMaker database field from numeric to text within the Manage 
Database -> Fields window.
2) Individually search for each value list numeric value, then use the Records -> Replace Field 
Contents feature to replace the numeric value with the value list text value.
3) Edit the contents of the actual static value list to remove the numeric value and its semicolon. 
The editing of the value list contents may be done either in FmPro Migrator or within FileMaker.
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Step 7 - FileMaker 16+ Copy Value Lists to Clipboard

FileMaker Pro Advanced 16 and higher versions include a new feature enabling the copy & paste 
of Value Lists via the clipboard. FmPro Migrator supports this new feature with a new button on 
the Value Lists tab.
Click the Copy All Value Lists to Clipboard button.
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Step 7 - FileMaker 16+ Paste Value Lists into Manage Value Lists Window

FmPro Migrator will:
1) Put the Value Lists data onto the clipboard in the correct format for FileMaker to read.
2) Open the Manage Value List s window.
3) Automatically enter Command-V (macOS) or Control-V (Windows) which instantly pastes the 
Value Lists into the Manage Value Lists window.

Notice in this screenshot, that all Custom and Field based Value Lists have been created 
automatically. 

From here, you may Click the Ok button to save the new Value Lists, make changes  or click the 
Cancel button.
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FileMaker 16+ Create Value Lists

When using FileMaker 16+, if you click the "Create All Value Lists in FileMaker" button, you will be 
prompted to use the new "Copy All Value Lists to Clipboard" button.

FileMaker 11 - 15 - Create Value Lists - Click Create All Value Lists Button

Click the Create All Value Lists button.

Click on the Create All Value Lists in FileMaker button to automate the creation of the Value Lists 
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using WinAutomation(Windows)/AppleScript(macOS).

Converted Value Lists - Within FileMaker Pro Manage Value Lists Window

The created Value Lists as displayed within the Manage Value Lists window.
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Using the Microsoft Access Code Conversion Workbench - Access to FmPro 
Conversions

This chapter shows how to use the Microsoft Access Code Conversion Workbench - included with 
the AI Accelerated version of FmPro Migrator. This feature replaces copying the unconverted 
scripts into the FileMaker Pro database as was done previously. Before performing the code 
conversion with the Microsoft Access Code Conversion Workbench, you should have already 
imported the Microsoft Access database into FmPro Migrator, including tables, relationships, 
value lists, forms/reports and scripts.

Access to FmPro Migration Button - GUI Tab

Click the Access to FmPro Migration button on the GUI tab of the Migration Process window of 
FmPro Migrator.

https://www.fmpromigrator.com/services/access_to_fmpro_service.html
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Access to FmPro Migration Window

Prior to reaching this step, you should have, (1) selected the AccessDDRExport text file and (2) 
clicked the Migrate button to import the Access database metadata into FmPro Migrator. You may 
have already started building the new FileMaker Pro database which would mean that you are 
ready (3) to click the Code Conversion Workbench button.
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Microsoft Access Code Conversion Workbench Window

By default, the Microsoft Access Code Conversion Workbench window opens with the (1) scripts 
listed in the grid, (2) Microsoft Access selected as the Source Database Type and (3) FileMaker 
Pro selected as the destination language.

Just because the options are selected a certain way when the window opens, doesn't mean you 
can't change them. You can easily change the default settings on this window for Output 
Language, Vendor, API Key Type, or AI Model - and the changes will be saved into the project or 
application preferences for FmPro Migrator.
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Microsoft Access Code Conversion Workbench Demo

If you forgot to enter your license key or didn't have a license for the AI Accelerated version of 
FmPro Migrator, then the Microsoft Access Code Conversion Workbench will open in Demo mode.
A previously converted set of sample scripts will be displayed in the grid instead of the scripts 
from your own Microsoft Access database. Clicking any of the scripts will display the text "This 
demo only includes a few scripts." in the Source Script field.
[At the present time, there aren't any Microsoft Access demo scripts.]
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Creating FileMaker Scripts from Visual Basic Code - Access to FmPro

Note: This is the legacy script copying feature which copies the commented Visual Basic scripts 
from Access into FileMaker Pro. This feature is replaced with the new Code Conversion 
Workbench feature included with the AI Accelerated version of FmPro Migrator.

The copying of the scripts from FmPro Migrator to FileMaker should occur before creating the 
layouts. The layouts will typically contain buttons linked to the scripts, therefore the scripts need to 
be available within FileMaker at the time the layouts are created.

Scripts List

Click on the Scripts tab of the Migration Process window to display the list of converted Scripts. 
Clicking on a Script in the list will display its contents.

Click on the Copy All Scripts to ClipBoard button to copy the scripts onto the clipboard.
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Pasted Scripts into the Manage Scripts Window

Select the Scripts -> Manage Scripts menu item to open the Manage Scripts window within 
FileMaker. 

Select Paste from the Edit menu to paste the scripts.
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Script Details - Converted Access Queries

In addition to converting Visual Basic Subroutines and Functions into FileMaker Scripts, FmPro 
Migrator also converts Microsoft Access Queries into FileMaker Scripts. Each Microsoft Access 
Query is converted into a Script using the SHPartners/myFMButler DoSQL plug-in from 
myFMButler to implement the SQL code of the original Query.

http://www.myfmbutler.com
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Creating Layouts - Access to FmPro

FileMaker Themes with FileMaker 12+

FmPro Migrator includes a template database FileMakerDB.fp7/FileMakerDB.fmp12 which is 
exported automatically for your use. When using FileMaker 12+ versions, the FileMakerDB.fmp12 
file is used. This database has been configured to use the Minimalist theme by default. Using this 
theme will insure that all layout objects look as closely as possible to their original style within the 
original Access database. 

Note: Some objects (like rectangles), will lose their fill and border color if the theme is changed 
on the layout. So if you want to change the theme, please be aware that you may need to manually 
change the colors of some objects.
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     Step 7 - Automatically Save Layout Changes Preference (macOS) - [1st Time Setup Step]

Select the FileMaker Preferences menu item, (1) click the Layouts tab, (2) click the checkbox to 
enable the "Save layout changes automatically (do not ask)" option, then (3) click the OK button.
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     Step 7 - Automatically Save Layout Changes Preference (Windows) - [1st Time Setup Step]

One of the important tasks listed in the WinAutomation Installation PDF file is to set the "Save 
layout changes automatically" option within the FileMaker Advanced Preferences dialog.
Select the FileMaker Preferences menu item, (1) click the Layouts tab, (2) click the checkbox to 
enable the "Save layout changes automatically (do not ask)" option, then (3) click the OK button.
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Layouts List

Click on the Layouts tab of the Migration Process window to display the list of converted Layouts. 
Clicking on a Layout in the list will display the details for the layout.
The converted form shown in this screenshot of the list of Layouts, shows a layout named (1) 
Assets which will be created within the FileMaker database with one (2) portal. The portal will be 
created in the location shown in yellow within the empty Layout Image box. This Layout was 
created from a Form within the Access database which had a SubForm embedded within the 
original form. FmPro Migrator will convert this SubForm into a FileMaker portal, related to the base 
table associated with the original SubForm. The portal fields will automatically be created and 
placed within the portal on the new FileMaker layout.

Click on the Create All Layouts in FileMaker button to automate the creation of the Layouts using 
WinAutomation(Windows)/AppleScript(macOS).

Note: The pop-up menu below this button should be left at its default value of "Pass 1".
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Converted Layout - Displayed Within FileMaker Pro

The converted Assets form from Microsoft Access is shown in Layout mode within FileMaker Pro. 
Embedded graphics, rectangles, fields, checkbox/radio button groups and drop down calendar 
pickers are implemented within FileMaker in the same manner as they were displayed within the 
original Access Form.
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Manual Completion Tasks
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Manual Tasks - Access to FmPro

There are some processing steps which must be completed manually when performing an 
Access to FileMaker Migration.

Layout Parts - Header, Footer, Subsummary

Microsoft Access incorporates Form/Report part objects with similar functionality to FileMaker 
layout parts. However there is not any method available to specify the inclusion of layout parts or 
the placement of objects within these parts when pasting FileMaker layouts via the clipboard. 
These layout parts will need to be added manually.

Unsupported Form/Report Objects

Some objects implemented on Microsoft Access Form/Reports do not have equivalent features 
within a FileMaker database:

acToggleButton - FmPro Migrator creates these objects as regular buttons on the layout.
acBoundObjectFrame - These are created as regular field objects, using the table/field specified 
within the original object.
acObjectFrame - These are created as regular field objects, using the table/field specified within 
the original object.
chart - Access database charts should be manually re-created by using the FileMaker chart 
object. This feature can also be implemented using a variety of plug-ins (i.e. xmChart) or add-ons 
which can use the WebViewer to display rendered JavaScript code (i.e. FusionCharts for 
FileMaker). 
acCustomControl - An acCustomControl can represent any compiled ActiveX dll installed for use 
with Microsoft Access. These types of features can usually be replaced with FileMaker plug-ins 
available from a variety of vendors.

http://www.x2max.com
http://www.fusioncharts.com/
http://www.fusioncharts.com/
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Relationship Testing

Within Access databases, there are no TOs within the database structure. All Forms/Reports and 
fields are tied directly to a base table, SQL Query or view within the database. When creating the 
Access relationships within a FileMaker database, additional TOs will often be created 
automatically. It will be necessary to review the additional TOs to verify whether the base table or 
the new TOs should be used.

Access database files may contain Left Outer Join or Right Outer Join relationships not directly 
supported in FileMaker. FmPro Migrator will create all Access relationships as equijoin 
relationships. However the text description about the original relationship will be displayed in the 
normally unused SQL code field of each converted relationship, as shown above.
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Portal Field Sizes

FmPro Migrator automatically creates a new portal to represent any SubForms/SubReports found 
on the original Access Form/Report. Unlike FileMaker portal objects, Access SubForm/SubReport 
objects contain horizontal scrollbars. Therefore there could be too many fields incorporated on the 
original SubForm/SubReport to make a readable display within the area of the new FileMaker 
portal. FmPro Migrator divides the width of the portal by the number of fields and creates each 
field of the same size. The fields are also created in the same left to right display order as they 
were created on the original SubForm/SubReport. Therefore some objects surrounding the portal 
may need to be moved and the portal may need to be enlarged to support a readable display of 
large numbers of fields. It may also be helpful to manually resize the individual portal fields to 
accommodate the actual data which will be displayed within the portal fields.
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Visual Basic Code Conversion with the Microsoft Access Code Conversion Workbench

The Microsoft Access Code Conversion Workbench feature is included with the AI Accelerated 
edition of FmPro Migrator. Each VBA script can potentially be converted into FileMaker script code 
by an AI model. Once converted, clicking the clipboard icon copies the commented script code 
onto the clipboard for pasting into the FileMaker Pro script workspace window. The script is also 
written to disk as a text file.

Each script step is commented, and the text can be copied into a new script script step.
This converted code is intended to serve as a template for the writing of new FileMaker script 
functionality. Many Visual Basic commands can be deleted, because they incorporate functionality 
which is not needed or doesn't exist within a FileMaker database. All commands will need to be 
carefully examined in order to replicate the original program logic as functional FileMaker script 
steps.

More details about using this feature are included in the "Using the Microsoft Access Code 
Conversion Workbench" section of this manual.
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Button Linking

FmPro Migrator automatically links buttons scripts on the original Access forms to scripts with the 
same names in the new FileMaker Pro database. Form event code is extracted from the Access 
database, with the VBA code commented to show the original business logic. This functionality 
will need to be rewritten within FileMaker scripts. The Code Conversion Workbench feature can 
provide a significant amount of help with this process.

Query Conversion & Multi-Table Joins

Access Queries are converted into TOs on the RelationshipGraph and are also converted into 
FileMaker scripts. The entire SQL code of the original Access query is available for review. 
FileMaker TOs, can only reference a single table, so to implement a multi-table join as shown in 
this SQL code, additional TOs and corresponding relationships would need to be manually 
added to the FileMaker  RelationshipGraph.
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Unbound Calculated Form Fields

Access Form/Report fields can be implemented as calculation fields not directly referenced to a a 
field in a database table. These fields can potentially be created as new calculated fields within a 
related table in the converted FileMaker database file. In some cases, a centrally located global 
field may be a more appropriate implementation.

Overlapping Layout Objects

There isn't any method to determine the top to bottom stacking order of objects on an Access 
Form/Report. FmPro Migrator builds objects within the new FileMaker Layout in a specific logical 
order to minimize issues with overlapping objects. The order of creating layout objects is:
Rectangle
Line
Graphic Image
Text Label
Field

Some cosmetic changes will potentially still need to be performed manually to fine tune the 
stacking order.
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